GoKunming Forums

Any Linux users? I need help.

Elisa (174 posts) • 0

I have a netbook running UNR, and I can't get it to connect to my DSL connection in my apartment. I've done what I would normally do, and the ubuntu forums are shockingly not much help.

It's a wired connection...wireless works fine but I have to go to a cafe to get that.

Ouyang (243 posts) • 0

How did you setup PPPoE? I think in ubuntu it just calls it "DSL". With 9.10 I also had problems with the managed connection, and had to set it up manually using pppoeconf

Ouyang (243 posts) • 0

Also have you done any updates using the wireless connection? The problem was quite common and has supposedly been fixed.

Elisa (174 posts) • 0

Right after I posted this I figured out what to search for and used the pppoeconf. I found this thread: ubuntuforums.org/showthread.php?t=1308020&highlight=PPPoE
and did the ppa thing and now I'm really not sure what's going on.

Network manager is now telling me "device not managed" under the wired network, but my vpn connection is not greyed out as it was before the reboot. I am obviously connected, but network manager still doesn't realize it. I'm pretty confused here.

Ouyang (243 posts) • 0

Yes, that's how mine is currently set-up. Mine is manually configured to automatically connect through pppoeconf. Sometimes the connection drops out for whatever reason and I have to run the following command to reconnect:

sudo pon dsl-provider

The problem is supposed to be fixed, and after updating you should be able to use the "managed device" in Ubuntu. I've never looked into how to re-enable the "managed device" part though, maybe this weekend I will look into it.

Ouyang (243 posts) • 0

I was able to re-enable the managed device with the first one, but I still have problems connecting with DSL the normal way. In the end I used pppoeconf to connnect automatically at startup, and have to run sudo pon dsl-provider if I get disconnected.

I never had this problem with previous versions of Ubuntu. For some the problem is apparently fixed after updating, and for others like myself it's obviously not fixed... kind of a pain to always use pon dsl-provider when I lose my connection... though I guess once could create an icon on the desktop to do that.

Elisa (174 posts) • 0

After some additional futzing around and a reboot, the first one worked, and I'm now connected through network manager and my vpn.

Thank you so much. I guess what I've learned from this is to see each failure as an entirely new error that must be searched anew :) I hope you also get yours working.

Related forum threads

Login to post