Wonders Of Yunnan Travel

Forums

My mac needs reviving...

skittles (11 posts) • 0

My old G4 Powerbook is acting funny and I don't know why, excuse me while I kiss the sky (sorry couldn't resist.)
Does anyone know a place in town? Maybe English friendly?

Thanks for everything SJ!

laotou (1715 posts) • 0

Did you try re-downloading and re-installing the latest system software updates and patches?

Pierre (45 posts) • 0

Hi, Macs are not my specialty, but as everybody knows, they do not have any flaws or need any repairing on the software-side ever... (sorry, couldn't resist too)
I don't know any English friendly repair shops here in Kunming, sorry. There are some shops already mentioned here on GoKunming, you can search for the threads.

Then, I know that Macs sometimes act up because of the virtual printers printing-cue. Another reason are problems with your file access permissions, try repairing those first. You could also try a hard-reset, there's a short-cut combo for this one (and it's not just taking out the battery and rebooting, this one does more).

If you give us more specific information on how you G4 is acting up, we maybe can give you more specific answers.

blobbles (957 posts) • 0

Most people don't realise but all Apple products have secret programming in them which links them to the life signs of Steve Jobs. Once he dies, all Apple products will last for maximum of 1 year but can fail at any point within that year. Looks like yours is one of the early ones.

OK OK, bad joke, what is actually wrong? "Acting funny" isn't really too good of a description! How full is your hard drive? Do you get errors on start up? If so what? Do you get any errors at all? Or is it just slow?

skittles (11 posts) • 0

It's a second generation G4 Powerbook. Yup, old. It'd been working splendidly up until recently (before the passing of it's daddy) when it just wouldn't start up one day. I tried the hard reset shift-control-option & power button for 5 seconds and low and behold it worked, about 5 times than stopped being so friendly. Up until then it had been fine performance wise, maybe a little slow but the ol' bessie is about 9 years old. Since than all I get is the occasional sound of the dvd-r trying to eject nothing when I try and start it up and a little internal hard drive noise. I was thinking maybe the monitor went on the blink so I hooked it up to an external to no avail. I've got external fire wire drives, the old 400's, with all of my back-ups but no way to access them sans my laptop or anything with a 400 jack. Now I'm on an Ubuntu rig that's doing just fine but I'd like to get that stuff off those drives and if possible watch my old aluminum buddy come back to life. It's been down for a couple months but with Steve Jobs passing and me feeling oddly emotional about the whole thing it'd be cool to have it back.

joshwa (67 posts) • 0

You can at least remove the hard drives from their enclosures (and from the laptop) and stick them in new USB enclosures to retrieve the data. Should be able to buy enclosures around town, or on newegg.cn.

laotou (1715 posts) • 0

1. See if you can put the laptop into firewire mode.

support.apple.com/kb/ht1343

2. IF that works AND you have external drives - Install OS X on an external firewire drive and reboot from the external drive. As an alternative, you can also try the PRAM zap trick (see above link). Do that a couple of times.

3. Assuming you boot from the external firewire drive, COPY all your important stuff to the backup.

4. DISK FIRST AID - run DFA on the internal drive - do it a couple of times (REPAIR, not VERIFY).

5. Try to download and install the latest OS patches (10.5.8) for your laptop - see if that brings it back to life.

6. Second Last Resort - Re-install the OS on the internal drive (but do NOT use the erase disk option).

Other things - the battery is probably toast - so make sure when you plug the adapter in, you're getting a light on the adapter plug. Also, check the battery power (push the button on the battery pack - how many lights light up?). If the battery pack is bulged - you need to get rid of it - it's gonna catch fire.

The internal LiON battery is definitely dead - but replacing it is a major PITA - and really it's only a pain when you power down the laptop - you just lose the time and date settings.

You may also want to try removing and reseating the RAM. That's not supposed to require rocket science - just make sure you've UNPLUGGED the power adapter.

LAST RESORT
Erase the drive and re-install OS X along with all the software updates.

NOTE - sometimes a software update can become corrupted during download - despite the CRC etc integrity checks. Also, sometimes a software update can be fine - but just install improperly (fragging your OS somewhat irreparably). I've found that once you recover all your important data & files - it's usually quicker to erase the hard drive (a couple of times) and re-install the OS and all those apps - which sucks up ludicrous time.

If this is a workhorse laptop - you MAY want to opt for a new hard drive - assuming all the other HW is fine - however I still plod along with my 60gb and 80gb internal drives on my old G4 laptops (17").

I've also had intermittent problems with airport reliability on newer G4 laptops - eg ibook. The thing will connect to unencrypted airports - but can't even see one of my airport expresses (the old 802.11bg airports) - they're identical (apparently not) but the ibook refuses to connect to the primary airport. This turned out to be the result of a bizarre OS installation.

harukimurakami (27 posts) • 0

my g4 died a similar death last year. that's the problems with macs, one day they're fine, the next they're terminal. at least windows machines give you signs of their withering decline into scrap metal.

skittles (11 posts) • 0

@laotou
I finally got around to trying your idea but I wasn't able to get it into firewire mode. Just nothing. The battery is toast. No lights on it but the AC adapter is green than orange or vice versa. Haven't tried resetting the RAM yet but wanted to say thanks for all the help. I may just drop it off at a shop and cross my digits. I'll let you know.

@joshwa
I'll try the swap but if they're old firewire 400 drives won't the USB not connect?

Thanks again everyone!

Login to post Register to post